Managing your Ruby version

CloudCannon supports Ruby versions using rbenv. Jekyll sites without the version specified default to version 2.7.x.

Versions installed are:

  • 2.4.6
  • 2.4.10
  • 2.5.5
  • 2.5.8
  • 2.5.9
  • 2.6.2
  • 2.6.6
  • 2.6.7
  • 2.7.1
  • 2.7.3
  • 3.0.0
  • 3.0.1
Note

If you require a Ruby version not listed above, please contact support. We will do our best to accommodate your needs.

Setting your version

To set your version add a .ruby-version file in the root folder. This file should contain one of versions specified above.

Here’s an example .ruby-version:

.ruby-version
2.6.2

Install rbenv on your local environment to ensure the same version is used. It is considered best practice to set your ruby version per project. This ensures that local builds and CloudCannon builds use the same version of Ruby.

Was this article helpful? or Suggest an improvement >

Other Resources

  1. Installing Ruby